Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на
выбор): 1. Вывод суммы натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно. 2. Вывод произведения натуральных чисел в заданном диапазоне Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы соответственно Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.Ответы на вопрос
Ответ:
Задача 1
var
i, sum, n1, n2: integer;
begin
readln(n1, n2);
for i := n1 to n2 do
sum := sum + i;
writeln(sum);
end.
Задача 2
var
i, n1, n2: integer;
p: BigInteger;
begin
p := 1;
readln(n1, n2);
for i := n1 to n2 do
p := p * i;
writeln(p);
end.
Для решения задачи выберем второй вариант: напишем программу на языке Pascal, реализующую алгоритм вывода произведения натуральных чисел в заданном диапазоне.
pascalprogram ProductInRange; var N1, N2, Product: Integer; function CalculateProduct(N1, N2: Integer): Integer; var i: Integer; begin Result := 1; // Инициализируем произведение единицей for i := N1 to N2 do Result := Result * i; // Умножаем текущее произведение на текущее число i end; begin // Ввод данных Write('Введите нижнюю границу диапазона (N1): '); Readln(N1); Write('Введите верхнюю границу диапазона (N2): '); Readln(N2); // Проверка входных данных if (N1 < 0) or (N2 < 0) or (N1 > 255) or (N2 > 255) then begin Writeln('Ошибка: Нижняя и верхняя границы должны быть от 0 до 255.'); Exit; // Завершаем программу end; // Рассчитываем произведение Product := CalculateProduct(N1, N2); // Вывод результата Writeln('Произведение всех натуральных чисел от ', N1, ' до ', N2, ' равно: ', Product); end.
Программа сначала запрашивает у пользователя нижнюю и верхнюю границы диапазона (N1 и N2). Затем она проверяет входные данные на соответствие условию (числа должны быть от 0 до 255). После этого программа вызывает функцию CalculateProduct, которая вычисляет произведение всех натуральных чисел от N1 до N2 включительно. Наконец, программа выводит результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
