С клавиатуры вводятся 10 чисел Написать программу, которая определяет наименьшее и наибольшее.
Pascal ABCОтветы на вопрос
const
n=10;
type
mas = array [1..n] of real;
procedure search(massive : mas);
var j : integer;
max, min : real;
begin
max := 1;
min := 1;
for j:=1 to n do
begin
if massive[j] > max then
max := massive[j];
if massive[j] < min then
min := massive[j];
end;
writeln;
writeln('наибольший элемент: ', max);
writeln('наименьший элемент: ', min);
end;
var
i : integer;
a : mas;
begin
writeln('введите массив: ');
for i:=1 to n do
read(a[i]);
writeln('массив: ' );
for i:=1 to n do
write(a[i]:4);
search(a);
end.
Sure, here's a simple Pascal ABC program that reads 10 numbers from the keyboard and determines the smallest and largest numbers among them:
pascalprogram MinMaxFinder; var numbers: array[1..10] of Integer; i, minValue, maxValue: Integer; begin writeln('Enter 10 numbers:'); for i := 1 to 10 do begin write('Enter number ', i, ': '); readln(numbers[i]); end; minValue := numbers[1]; maxValue := numbers[1]; for i := 2 to 10 do begin if numbers[i] < minValue then minValue := numbers[i]; if numbers[i] > maxValue then maxValue := numbers[i]; end; writeln('The smallest number is: ', minValue); writeln('The largest number is: ', maxValue); end.
Copy and paste this code into your Pascal ABC IDE and run it. It will prompt you to enter 10 numbers one by one and then display the smallest and largest numbers among them.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
