Составить программу покупки Если стоимость покупки меньше 500- скидки нет. Если больше 1000-10%
Если от 500 до 1000-5%Ответы на вопрос
        Ответ:
var sum : real;
begin
writeln('Введите сумму покупки');
readln(sum);
if (sum < 500) then
writeln('Скидки нет')
else
if ((sum >= 500) AND (sum <= 1000)) then
writeln('Скидка 5%')
else
if (sum > 1000) then
writeln('Скидка 10%');
end.
            Для составления программы покупки, которая рассчитывает скидку в зависимости от стоимости покупки, можно использовать следующий код на языке программирования Python:
pythondef calculate_discount(purchase_cost):
    if purchase_cost < 500:
        return 0
    elif purchase_cost >= 500 and purchase_cost <= 1000:
        return 0.05
    else:
        return 0.1
def main():
    try:
        purchase_cost = float(input("Введите стоимость покупки: "))
        
        if purchase_cost < 0:
            raise ValueError("Стоимость покупки не может быть отрицательной.")
        
        discount_percentage = calculate_discount(purchase_cost)
        discount_amount = purchase_cost * discount_percentage
        final_cost = purchase_cost - discount_amount
        
        print(f"Скидка: {discount_amount:.2f}")
        print(f"Итоговая стоимость: {final_cost:.2f}")
    except ValueError as ve:
        print(f"Ошибка: {ve}")
if __name__ == "__main__":
    main()
Когда программа запускается, она попросит пользователя ввести стоимость покупки. Затем она рассчитает процент скидки в зависимости от стоимости покупки, вычислит сумму скидки и итоговую стоимость покупки, и выведет эти значения на экран.
Пожалуйста, обратите внимание, что в коде предполагается, что пользователь вводит корректное числовое значение стоимости покупки, и программа обрабатывает только неотрицательные значения. В реальном приложении стоит реализовать более подробную обработку ошибок и валидацию пользовательского ввода.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			