Вопрос задан 13.07.2023 в 10:45.
Предмет Информатика.
Спрашивает Киванов Артур.
Задание на Паскале: составить программу для вычисления суммы целых чисел от 117 до 234. Помогите,
пожалуйстаОтветы на вопрос
Отвечает Тареева Виктория.
var s, i: integer;
begin
s := 0;
for i := 117 to 234 do
s := s + i;
write('Сумма целых чисел от 117 до 234 равна ', s);
end.
Отвечает Кукарцев Никита.
Ответ:
Pascal ABC.Net
begin
var s: integer;
for var i := 117 to 234 do
s+=i;
Println('Sum: ',s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам с этой задачей. Вот простая программа на языке Pascal, которая вычисляет сумму целых чисел от 117 до 234:
pascalprogram SumOfIntegers; var i, sum: integer; begin sum := 0; // Инициализируем переменную sum нулевым значением for i := 117 to 234 do begin sum := sum + i; // Добавляем значение i к текущему значению sum end; writeln('Сумма чисел от 117 до 234: ', sum); // Выводим результат на экран end.
Сохраните этот код в файл с расширением .pas, например, sum_of_integers.pas. Затем, используя компилятор Pascal (например, Free Pascal), скомпилируйте и запустите программу. Она вычислит и выведет сумму чисел от 117 до 234 на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
