Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел
от 1 до n. В каждой строке надо напечатать очередное число и столько символов “+”, сколько делителей у этого числа. Например, если n = 4, то на экране должно быть напечатано: 1+ 2++ 3++ 4+++Ответы на вопрос
Код на Pascal выводит точно то, что требуешь )). Напомню лишь, не забудь про отступы, когда будешь писать/копировать код. Удачи! )):
var i,j,m,n: integer;
pl{,i_s}: string;
begin
pl:= '';
writeln('Enter n: n = ');
readln(n);
for i:= 1 to n do
begin
for j:= 1 to i do
begin
pl:= pl + '+';
end;
//i_s:= string(i);
writeln(i{_s},' ',pl);
pl:= '';
end;
end.

Вот пример программы на языке Паскаль, которая выводит графическое изображение делимости чисел от 1 до n:
pascalprogram DivisibilityGraph; var n, i, j: integer; begin write('Введите значение n: '); readln(n); for i := 1 to n do begin write(i); for j := 1 to i do begin if i mod j = 0 then write('+') else write(' '); end; writeln(); end; readln(); end.
В данной программе используется два вложенных цикла. Внешний цикл for i := 1 to n отвечает за итерацию по числам от 1 до n. Внутренний цикл for j := 1 to i проверяет, является ли j делителем числа i. Если это так (i mod j = 0), то выводится символ "+", в противном случае выводится пробел. После завершения внутреннего цикла выводится новая строка.
Программа сначала запрашивает у пользователя значение n и затем выводит графическое изображение делимости чисел от 1 до n в соответствии с описанными условиями.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
