Вопрос задан 13.07.2023 в 05:57. Предмет Информатика. Спрашивает Рябчук Вика.

Помогите составить программу в Паскале 25 баллов!! Ресторан закупает ежедневно Z1 кг масла по

188,50 р/кг, Z2 кг сметаны по 95 р/кг, Z3 кг сливок по 104,50 р/кг. Цена товара определяется командой присваивания, количество – командой ввода. Программа должна определить суммы, необходимые для покупки отдельных товаров и общую сумму.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Грибакин Вадим.

var

 sum, a, b, c: real;

begin

 Write('Введите количество масла в кг.: ');

 Read(a);

 Write('Введите количество сметаны в кг.: ');

 Read(b);

 Write('Введите количество сливок в кг.: ');

 Read(c);

 sum := a * 188.5;

 Writeln('За ', a, 'кг. масла, получится: ', sum, 'р.');

 sum := b * 95;

 Writeln('За ', b, 'кг. сметаны, получится: ', sum, 'р.');

 sum := c * 104.5;

 Writeln('За ', c, 'кг. сливок, получится: ', sum, 'р.');

 Writeln('Общая сумма: ', (a * 188.5) + (b * 95) + (104.5), 'р.');

end.

Тестовое решение:

Введите количество масла в кг.: 6

Введите количество сметаны в кг.: 4

Введите количество сливок в кг.: 2

За 6кг. масла, получится: 1131р.

За 4кг. сметаны, получится: 380р.

За 2кг. сливок, получится: 209р.

Общая сумма: 1615.5р.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для составления программы на языке Паскаль для определения суммы, необходимой для покупки отдельных товаров и общей суммы, можно использовать следующий код:

pascal
program RestaurantPurchase; var Z1, Z2, Z3: real; PriceOil, PriceSourCream, PriceCream: real; SumOil, SumSourCream, SumCream, TotalSum: real; begin writeln('Введите количество масла (в кг): '); readln(Z1); writeln('Введите количество сметаны (в кг): '); readln(Z2); writeln('Введите количество сливок (в кг): '); readln(Z3); PriceOil := 188.50; PriceSourCream := 95; PriceCream := 104.50; SumOil := Z1 * PriceOil; SumSourCream := Z2 * PriceSourCream; SumCream := Z3 * PriceCream; TotalSum := SumOil + SumSourCream + SumCream; writeln('Сумма для масла: ', SumOil:0:2, ' руб.'); writeln('Сумма для сметаны: ', SumSourCream:0:2, ' руб.'); writeln('Сумма для сливок: ', SumCream:0:2, ' руб.'); writeln('Общая сумма: ', TotalSum:0:2, ' руб.'); end.

Этот код опрашивает пользователя о количестве масла, сметаны и сливок. Затем, используя предопределенные цены, он вычисляет сумму для каждого товара и общую сумму всех покупок. Выводится информация о сумме для масла, сметаны, сливок и общей сумме.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос