Порядок выполнения работы: Запустите программу Turbo Pascal. Выполните задания: 1. Ввести
одномерный массив на 10 элементов, состоящий из положительных и отрицательных чисел. 2. Заменить отрицательные элементы на противоположные по знаку. 3. Вывести полученный массив на экран. 4. Удалите из массива третий элемент. 5. Вывести полученный массив на экран. 6. Найдите сумму всех элементов массива. Зачетное задание Определить сколько раз встречается самое малое число в массиве А(1: 30)?Ответы на вопрос
program mas_kol_otr_kol_p;
const
n=10;
var
i,s:integer;
a:array[1..n] of integer;
begin
randomize;
writeln('Введите массив 》');
for i:=1 to n do
begin
a[i]:=random(61)-30;
write(a[i]:3,' ');
end;
writeln;
writeln('Меняем отрицательные на противоположные... 》');
for i:=1 to n do
begin
if(a[i]<0) then
a[i]:=abs(a[i]);
write(a[i]:3,' ');
end;
writeln;
writeln('Удаляем третий элемент... 》');
for i:=1 to n-1 do
begin
if(i>2) then
a[i]:=a[i+1];
write(a[i]:3,' ');
end;
writeln;
writeln('Считаем сумму... 》');
s:=0;
for i:=1 to n-1 do
s:=s+a[i];
write(s);
end.

Для выполнения указанных заданий в Turbo Pascal, вам потребуется написать программу, которая решит каждую задачу по порядку. Вот общий шаблон программы, который поможет выполнить указанные задания:
pascalprogram ArrayOperations; const N = 10; // Количество элементов в массиве var A: array[1..N] of integer; i, minValue, minCount, sum: integer; begin // 1. Ввод массива writeln('Введите ', N, ' элементов массива:'); for i := 1 to N do begin readln(A[i]); end; // 2. Замена отрицательных элементов на противоположные for i := 1 to N do begin if A[i] < 0 then A[i] := -A[i]; end; // 3. Вывод полученного массива writeln('Полученный массив:'); for i := 1 to N do begin write(A[i], ' '); end; writeln; // 4. Удаление третьего элемента из массива // Проверяем, что в массиве есть хотя бы 3 элемента if N >= 3 then begin for i := 3 to N - 1 do begin A[i] := A[i + 1]; end; N := N - 1; end; // 5. Вывод массива после удаления третьего элемента writeln('Массив после удаления третьего элемента:'); for i := 1 to N do begin write(A[i], ' '); end; writeln; // 6. Нахождение суммы всех элементов массива sum := 0; for i := 1 to N do begin sum := sum + A[i]; end; writeln('Сумма всех элементов массива:', sum); // Зачетное задание: Поиск количества вхождений самого малого числа в массиве minValue := A[1]; minCount := 1; for i := 2 to N do begin if A[i] < minValue then begin minValue := A[i]; minCount := 1; end else if A[i] = minValue then begin minCount := minCount + 1; end; end; writeln('Количество вхождений самого малого числа (', minValue, ') в массиве:', minCount); end.
Вы можете скопировать этот код в среду разработки Turbo Pascal и запустить программу. После запуска программа попросит вас ввести 10 элементов массива. Затем она выполнит указанные задания и выведет результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
