
1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму
его элементов 2) дан одномерный массив найдите минимальный и максимальный элемент и выведите на экран

Ответы на вопрос

Ответ:
1)Program massiv;
Var mas:array[1..20] of integer;
a,b,i,sum:integer;
Begin
sum:=0;
For i:=1 To 20 Do
begin
mas[i]:= random(100); {Заполняем массив случайными числами в промежетке от 0 до 99 (можешь изменить промежуток}
write(mas[i],' ');
end;
Writeln('Введите a,b');
Readln(a,b);
For i:=1 To 20 Do
begin if (mas[i]>a) and (mas[i]<b) Then
sum:=sum+mas[i];
end;
Writeln(sum);
end.



1) дан одномерный массив найдите сумму всех элементов массива , выведи на экран сам массив и сумму его элементов
1)Program massiv;
Var mas:array[1..20] of integer;
a,b,i,sum:integer;
Begin
sum:=0;
For i:=1 To 20 Do
begin
mas[i]:= random(100);
в промежетке от 0 до 99 }
write(mas[i],' ');
end;
Writeln('Введите a,b');
Readln(a,b);
For i:=1 To 20 Do
begin if (mas[i]>a) and (mas[i]<b) Then
sum:=sum+mas[i];
nd;
Writeln(sum);
end.



Для решения задачи вам потребуется программирование. Я предоставлю вам пример решения на языке Python.
- Найдем сумму всех элементов массива и выведем его на экран:
python# Пример одномерного массива
arr = [1, 2, 3, 4, 5]
# Найдем сумму элементов массива
sum_arr = sum(arr)
# Выведем массив и сумму его элементов на экран
print("Массив:", arr)
print("Сумма элементов:", sum_arr)
- Найдем минимальный и максимальный элементы массива и выведем их на экран:
python# Пример одномерного массива
arr = [1, 10, 3, 4, 7]
# Найдем минимальный и максимальный элементы массива
min_element = min(arr)
max_element = max(arr)
# Выведем минимальный и максимальный элементы на экран
print("Минимальный элемент:", min_element)
print("Максимальный элемент:", max_element)
Вы можете изменить значения элементов массива arr
на свои или использовать другие массивы для решения задачи. Обратите внимание, что данные программы предполагают, что массив состоит из чисел. Если массив содержит нечисловые элементы, также потребуется дополнительная обработка.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili