Вопрос задан 11.07.2023 в 20:29. Предмет Информатика. Спрашивает Галас Діма.

Написать программу которая вычесляет индэкс массы тела

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лаптев Саня.

Ответ:

import pause

from colorama import Back, Fore, Style

languge = input('Пожайлуста выбери язык.Plese coose languge.Оберіть мову будьласка(ru, ukr, en): ')

if languge == 'ru':

ask = input('Привет я программа которая измеряет соотношение веса и роста.Ну что готов(y / n): ')

if ask == 'n':

 print("Жаль.Пока")

if ask == 'y':

 rost = float(input( 'Введи свой рост в метрах(1.7): '))

 ves = float(input('Введи вес в килограммах: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print('Парень(девушка) да ты тощак едь к бабушке она все поправит ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print('Все ок ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print('Беги в зал пока не позно а иначе светит Ожирение 1 степени ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print( 'Одна булочка на ночь это ничего говорил он(-а) вот ты теперь Жирдяй 1 степени (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '*Фейс палм* ну что доигрался жирдяй 2 степени ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Тебе пульт подать он же на твоем 2 метровом пузе (。・∀・)ノ゙')

if languge == 'ukr':

ask = input('Привіт я програма яка вимірює співвідношення ваги і роста.На що готовий(y / n): ')

if ask == 'n':

 print( "Жаль.Бувай")

if ask == 'y':

 rost = float(input( 'Введи свій зріст в метрах(1,.7): '))

 ves = float(input('Введи вагу в кілограмах: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print('Хлопець (дівчина) та ти тощак їдь до бабусі вона все виправить ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print( 'Все ок ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print( 'Біжи в зал поки не пізно а інакше світить Ожиріння 1 ступеня ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print('Одна булочка на ніч це нічого говорив він (-а) ось ти тепер жирдяй 1 ступеня (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '* Фейс палм * ну що догрався жирдяй 2 ступеня ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Тобі пульт подати він же на твоєму 2 метровому пузі (。・∀・)ノ゙')

if languge == 'en':

ask = input('Hi, I’m a program that measures the ratio of weight to height. Well, what is ready(y / n): ')

if ask == 'n':

 print( "Sorry, bye")

if ask == 'y':

 rost = float(input( 'Enter your height in meters(1.7): '))

 ves = float(input('Enter the weight in kilograms: '))

 soothohenie = float( ves / (rost ** 2))

 if soothohenie < 18.5:

  print( 'Boy (girl), yes you are a fasting man going to grandmother, she will correct everything ¬_¬')

 elif (soothohenie >= 18.5 and soothohenie <=  24.9):

  print( 'All OK ^_^')

 elif (soothohenie >= 25.0 and soothohenie <= 29.9):

  print( 'Run into the hall until it’s a shame, otherwise Obesity of the 1st degree ╰(‵□′)╯')

 elif (soothohenie >=30.0 and soothohenie <= 34.9):

  print( 'One bun for the night, it said nothing (s) here you are now Fatty 1 degree (っ °Д °;)っ')

 elif (soothohenie >= 35.0 and soothohenie <= 39.9):

  print( '* Face palm * well, that got fat 2 degrees ⊙﹏⊙∥')

 elif soothohenie > 40:

  print( 'Give you the remote control, it’s on your 2 meter belly (。・∀・)ノ゙')

pause.seconds(30)

Объяснение:

0 0
Отвечает Шашок Артём.

Ответ:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

#include <iostream>

using namespace std;

 

int main()

{   setlocale (LC_ALL, "Russian");

   int feets;

   int duyms;

   int funt;

   cout << "Введите рост в футах и дюймах ";

   cin >> feets;

   cin >> duyms;

   cout << "ВВедите вес тела в фунтах ";

   cin >> funt;

   const int duym = 12;

   const double metr = 0.0254;

   const double kilo = 2.2;

   int Duyms = feets*duym+duyms;

   int meters = Duyms*0.0254;

   int Kilogramm = funt/kilo;

   double BMI = Kilogramm /(meters*meters);

   cout <<"Ваш BMI равен: " << BMI;

   return 0;

   

}

Объяснение:

на C ++

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот простая программа на языке Python, которая вычисляет индекс массы тела (ИМТ) на основе введенного пользователем веса и роста:

python
def calculate_bmi(weight, height): # Проверяем, чтобы вес и рост были положительными числами if weight <= 0 or height <= 0: return "Ошибка: Вес и рост должны быть положительными числами!" # Формула для вычисления ИМТ: вес (кг) / (рост (м) в квадрате) bmi = weight / (height ** 2) return bmi def interpret_bmi(bmi): if bmi < 18.5: return "Недостаточная масса тела" elif 18.5 <= bmi < 24.9: return "Нормальная масса тела" elif 25 <= bmi < 29.9: return "Избыточная масса тела (предожирение)" elif 30 <= bmi < 34.9: return "Ожирение 1 степени" elif 35 <= bmi < 39.9: return "Ожирение 2 степени" else: return "Ожирение 3 степени" if __name__ == "__main__": try: weight = float(input("Введите ваш вес в килограммах: ")) height = float(input("Введите ваш рост в метрах: ")) bmi = calculate_bmi(weight, height) interpretation = interpret_bmi(bmi) print(f"Ваш индекс массы тела (ИМТ) равен: {bmi:.2f}") print(f"Интерпретация: {interpretation}") except ValueError: print("Ошибка: Некорректный ввод. Пожалуйста, введите числовое значение веса и роста.")

Программа попросит пользователя ввести свой вес и рост, а затем вычислит ИМТ и выдаст его интерпретацию. Пожалуйста, убедитесь, что вес указан в килограммах, а рост в метрах.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос