Составьте программу, определяющую, входит ли введенная вами цифра в десятичную запись введенного
вами двухзначного числа.(Паскаль)Ответы на вопрос
Ответ:
Вот от душиииииии=)),
Удачи в учебе

Конечно! Вот пример программы на языке Паскаль, который определяет, входит ли введенная цифра в десятичную запись введенного двухзначного числа:
pascalprogram CheckDigit; var number, digit: integer; begin writeln('Введите двухзначное число:'); readln(number); writeln('Введите цифру:'); readln(digit); if (digit >= 0) and (digit <= 9) then begin if (number >= 10) and (number <= 99) then begin if (number mod 10 = digit) or (number div 10 = digit) then writeln('Цифра ', digit, ' входит в число ', number) else writeln('Цифра ', digit, ' не входит в число ', number); end else writeln('Введенное число не является двухзначным.'); end else writeln('Введенное значение не является цифрой.'); readln; end.
В этой программе сначала запрашивается двухзначное число, а затем цифра. Затем программа проверяет, являются ли введенные значения допустимыми (число должно быть от 10 до 99, а цифра от 0 до 9). Если значения допустимы, программа проверяет, входит ли цифра в число. Если цифра входит, выводится сообщение об этом, в противном случае выводится сообщение о том, что цифра не входит в число.
Обратите внимание, что это только пример программы на языке Паскаль. Вам может понадобиться адаптировать ее под вашу среду разработки или добавить дополнительные проверки ввода, в зависимости от ваших требований.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
