Вопрос задан 11.07.2023 в 09:24.
Предмет Информатика.
Спрашивает Дворская Катерина.
Составьте программу, выясняющую, есть ли в двухмерном массиве А(N,M) строки, сумма элементов
которых есть отрицательное число ( ПАСКАЛЬ!) P.S. нужно, чтобы эта программа запустилась в с++Очень срочно!Ответы на вопрос
Отвечает Рахматуллин Никита.
===== PascalABC.NET =====
begin
var (n, m) := ReadInteger2('Введите n и m:');
var a := MatrRandom(n, m, -99, 99);
a.Println;
if a.Rows.Select(r -> r.Sum).Any(s -> s < 0) then
Print('Есть')
else
Print('Нет')
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, который проверяет наличие строк с отрицательной суммой элементов в двумерном массиве:
pascalprogram NegativeSumRows; const N = 5; // Количество строк M = 5; // Количество столбцов type Matrix = array[1..N, 1..M] of Integer; var A: Matrix; i, j: Integer; hasNegativeSumRow: Boolean; procedure FillMatrix(var A: Matrix); begin // Здесь можно заполнить матрицу случайными числами или ввести вручную // Например: // A[1, 1] := 1; A[1, 2] := -2; ... end; function RowSum(row: Integer; var A: Matrix): Integer; var j: Integer; begin Result := 0; for j := 1 to M do Result := Result + A[row, j]; end; begin FillMatrix(A); hasNegativeSumRow := False; for i := 1 to N do begin if RowSum(i, A) < 0 then begin hasNegativeSumRow := True; Break; end; end; if hasNegativeSumRow then writeln('В матрице есть строки с отрицательной суммой элементов.') else writeln('В матрице нет строк с отрицательной суммой элементов.'); end.
Пожалуйста, учтите, что этот пример написан на языке Паскаль, а не на C++, и вам может потребоваться некоторое преобразование кода, чтобы он работал на C++.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
