 
Вопрос задан 11.07.2023 в 07:20.
Предмет Информатика.
Спрашивает Садриев Инсаф.
ПОЖАЛУЙСТА, ОЧЕНЬ СРОЧНО!!!! Напишите программу, которая в последовательности натуральных чисел
определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи- вается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Улесова Софья.
                
    Ответ:
program z;
uses crt;
var
s,x: longint;
begin
s:=0;
read(x);
while (x<>0) do begin
if (x mod 10=4) and (x div 6=0) then
s:=s+x;
end;
write(s);
end.
Объяснение:
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на языке Python, которая решает вашу задачу:
pythondef find_sum():
    total_sum = 0
    while True:
        num = int(input("Введите число: "))
        if num == 0:
            break
        if num % 6 == 0 and num % 10 == 4:
            total_sum += num
    return total_sum
sum_result = find_sum()
print("Сумма чисел, кратных 6 и оканчивающихся на 4:", sum_result)
Эта программа будет запрашивать числа у пользователя до тех пор, пока не будет введен 0. Если введенное число кратно 6 и оканчивается на 4, оно будет добавлено к общей сумме. В конце программа выведет полученную сумму.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			