 
Вопрос задан 11.07.2023 в 07:20.
Предмет Информатика.
Спрашивает Саратова Марина.
Составить программу на языке Паскаль С клавиатуры вводится натуральное число К – количество
ошибок в контрольной работе. Программа выводит оценку за контрольную работу: «Молодец!», если К=0 «Хорошо», если К=1 или К=2 «Удовлетворительно», если К=3 или К=4 «Выучи тему!», если К>=5 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Мишина Полина.
                
    var K:integer;
begin
readln(K);
if K=0 then writeln('Молодец!')
else if (K=1) or (K=2) then writeln('Хорошо')
else if (K=3) or (K=4) then writeln('Удовлетворительно')
else if K=5 then writeln('Выучи тему!')
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для написания программы на языке Паскаль, которая решает данную задачу, следуйте инструкциям ниже:
pascalprogram GradeCalculator; var K: integer; begin // Вводим значение K с клавиатуры write('Введите количество ошибок K: '); readln(K); // Проверяем значение K и выводим соответствующую оценку if K = 0 then writeln('Молодец!') else if (K = 1) or (K = 2) then writeln('Хорошо') else if (K = 3) or (K = 4) then writeln('Удовлетворительно') else writeln('Выучи тему!'); end.
Программа предлагает пользователю ввести количество ошибок K с клавиатуры. Затем она проверяет значение K и выводит соответствующую оценку на экран.
Пожалуйста, убедитесь, что ваш компилятор или среда разработки поддерживает язык Паскаль и может выполнить этот код.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			