Вопрос задан 11.07.2023 в 02:05.
Предмет Информатика.
Спрашивает Журавлёв Михаил.
ЗАДАНИЕ НА ПАСКАЛЕ: написать программу и найти сумму целых чисел от 40 до 120, кратных 11
Ответы на вопрос
Отвечает Розанова Анна.
Ответ:
PascalABC.NET 3.5.1.2290 + .NET Framework 4.7.1
begin
Range(40, 120).Where(p -> p mod 11 = 0).Sum.Println;
end.
Отвечает Болатова Раушангүл.
Ответ:
Объяснение:
program sum;
var i,s:integer;
begin
s:=0;
i:=0;
for i:=40 to 120 do
begin
s:=s+i;
end;
writeln(s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая находит сумму целых чисел от 40 до 120, кратных 11:
pascalprogram SumOfMultiples; var num, sum: integer; begin sum := 0; for num := 40 to 120 do begin if (num mod 11 = 0) then sum := sum + num; end; writeln('Сумма целых чисел от 40 до 120, кратных 11: ', sum); end.
Программа использует цикл for для перебора всех чисел от 40 до 120 и проверяет, является ли текущее число кратным 11 (проверка num mod 11 = 0). Если число кратно 11, оно добавляется к общей сумме. В конце программы выводится результат - сумма кратных 11 чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
