Вопрос задан 10.07.2023 в 18:49.
Предмет Информатика.
Спрашивает Ващенко Даниил.
Паскаль в массиве 1.Составьте программу, которая в одномерном массиве размерностью 12 (элементы
случайные числа из промежутка от 1 до 9) подсчитывает количество чётных элементов. Оформите вывод элементов на экран в строчку, вывод количества чётных на следующей строке.2.Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент. Оформите вывод элементов на экран в строчку, максимальный на следующей строке.Ответы на вопрос
Отвечает Вольпин Максим.
Ответ:
PascalABC.NET 3.5.1
#1
begin
var A := ArrRandom(12, 1, 9);
A.Println;
A.Where(p -> p mod 2 = 0).Count.Println;
end.
#2
begin
var A := ArrRandom(8, 15, 100);
A.Println;
A.Max.Println;
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для обеих задач можно использовать язык программирования Pascal. Вот программы для каждой из задач:
- Подсчет количества четных элементов в массиве:
pascalprogram CountEvenElements; const ARRAY_SIZE = 12; var arr: array[1..ARRAY_SIZE] of Integer; i, evenCount: Integer; begin { Заполнение массива случайными числами от 1 до 9 } Randomize; for i := 1 to ARRAY_SIZE do arr[i] := Random(9) + 1; { Вывод элементов на экран } Write('Массив: '); for i := 1 to ARRAY_SIZE do Write(arr[i], ' '); { Подсчет количества четных элементов } evenCount := 0; for i := 1 to ARRAY_SIZE do begin if arr[i] mod 2 = 0 then Inc(evenCount); end; { Вывод количества четных элементов на следующей строке } Writeln; Writeln('Количество четных элементов: ', evenCount); end.
- Поиск максимального элемента в массиве:
pascalprogram FindMaxElement; const ARRAY_SIZE = 8; var arr: array[1..ARRAY_SIZE] of Integer; i, maxElement: Integer; begin { Заполнение массива случайными числами от 15 до 100 } Randomize; for i := 1 to ARRAY_SIZE do arr[i] := Random(86) + 15; { Вывод элементов на экран } Write('Массив: '); for i := 1 to ARRAY_SIZE do Write(arr[i], ' '); { Поиск максимального элемента } maxElement := arr[1]; for i := 2 to ARRAY_SIZE do begin if arr[i] > maxElement then maxElement := arr[i]; end; { Вывод максимального элемента на следующей строке } Writeln; Writeln('Максимальный элемент: ', maxElement); end.
Обе программы заполняют массив случайными числами и затем выполняют необходимые действия с массивом, выводя результаты на экран. При каждом запуске программы, массив будет заполнен новыми случайными числами, и результаты могут отличаться.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 37
Информатика 55
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
