Помогите написать программу на C++ Оформить функцию поиска количества нулевых элементов массива.
В главной программе дано 3 одномерных массива arr1,arr2,arr3 длиной 10 элементов каждый. Применить функцию для каждого из 3-х заданных массивов. (в функции не должно быть операторов ввода или вывода)Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
#define n 10
void fillingMass(int arr[n])
{
for(int i=0; i<n; i++)
{
arr[i] = -5 + rand() % 10;
cout<<arr[i]<<" "; // вывод содержимого массивов, если не надо уберешь
}
cout<<endl; // вывод содержимого массивов, если не надо уберешь
}
int countingZero(int arr[n])
{
int count = 0;
for(int i=0; i<n; i++)
{
if(arr[i] == 0)
count++;
}
return count;
}
int main()
{
int arr1[n],arr2[n],arr3[n];
fillingMass(arr1);
fillingMass(arr2);
fillingMass(arr3);
cout<<"In the first array, the number of zero elements = "<<countingZero(arr1)<<endl;
cout<<"In the second array, the number of zero elements = "<<countingZero(arr2)<<endl;
cout<<"In the third array, the number of zero elements = "<<countingZero(arr3)<<endl;
return 0;
}
Объяснение:

Для оформления функции поиска количества нулевых элементов массива в C++, следуйте следующему коду:
cpp#include <iostream>
// Функция поиска количества нулевых элементов в массиве
int countZeros(int arr[], int size) {
int count = 0;
for (int i = 0; i < size; i++) {
if (arr[i] == 0) {
count++;
}
}
return count;
}
int main() {
const int size = 10;
int arr1[size] = {1, 0, 5, 0, 3, 0, 8, 0, 0, 9};
int arr2[size] = {0, 0, 0, 0, 0, 0, 0, 0, 0, 0};
int arr3[size] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
int zeros1 = countZeros(arr1, size);
int zeros2 = countZeros(arr2, size);
int zeros3 = countZeros(arr3, size);
std::cout << "Количество нулевых элементов в arr1: " << zeros1 << std::endl;
std::cout << "Количество нулевых элементов в arr2: " << zeros2 << std::endl;
std::cout << "Количество нулевых элементов в arr3: " << zeros3 << std::endl;
return 0;
}
В этом коде создается функция countZeros, которая принимает массив и его размер в качестве параметров и возвращает количество нулевых элементов в массиве. Затем в главной программе объявляются три одномерных массива и применяется функция countZeros для каждого из них. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
