 
Вопрос задан 10.07.2023 в 13:28.
Предмет Информатика.
Спрашивает Гарбуз Влад.
Помогите написать программу на C++ задание: сколько трехзначных чисел, оканчивающихся на 7,
деляться на 3? 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Кузьменко Павел.
                
    Ответ:
#include <stdio.h>
int main()
{
int i,j,k,l,n;
n=0;
for (i=100; i<=999; i++)
{
j= i/100;
l=100*j;
k = j-l;
if (k==7)
n = n+1;
};
printf("N=%d\n",n);
exit(0);
}
Объяснение:
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на C++, которая считает количество трехзначных чисел, оканчивающихся на 7 и делящихся на 3:
cpp#include <iostream>
int main() {
    int count = 0;
    for (int num = 107; num <= 997; num += 10) {
        if (num % 3 == 0) {
            count++;
        }
    }
    std::cout << "Количество трехзначных чисел, оканчивающихся на 7 и делящихся на 3: " << count << std::endl;
    return 0;
}
Программа начинает с числа 107 (ближайшее трехзначное число, оканчивающееся на 7) и затем увеличивает число на 10 на каждой итерации, так как последняя цифра числа всегда должна быть 7. Затем проверяется, делится ли текущее число на 3, и если да, увеличивается счетчик. По завершении цикла программа выводит количество подходящих чисел.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			