 
Вопрос задан 10.07.2023 в 13:09.
Предмет Информатика.
Спрашивает Куга Диана.
(Паскаль) Напишите программу, которая для любого двухзначного числа выводит сумму его цифр.
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Михайлова Инесса.
                
    var a, x, s, i: integer;
begin
writeln('Введите целое число');
readln( a );
x:=a;
s:=0;
while ( x<>0 ) do
begin
s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на языке Паскаль, которая выполняет задачу:
pascalprogram SumOfDigits; var number, digit1, digit2, sum: integer; begin // Ввод числа write('Введите двухзначное число: '); readln(number); // Разбиение числа на цифры digit1 := number div 10; digit2 := number mod 10; // Вычисление суммы цифр sum := digit1 + digit2; // Вывод результата writeln('Сумма цифр числа ', number, ' равна ', sum); // Завершение программы readln; end.
Скопируйте этот код в среду разработки Паскаля и запустите программу. Она попросит вас ввести двухзначное число, а затем выдаст сумму его цифр.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			