Вопрос задан 10.07.2023 в 09:08.
Предмет Информатика.
Спрашивает Волкова Даша.
C++ Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой
цепочке. Входные данные: Входная строка содержит три целых числа, разделённых пробелами. Выходные данные: Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.Ответы на вопрос
Отвечает Pytaylo Dmitry.
Ответ:
#include <iostream>
int main()
{
int a, b, c;
std::cout << "Enter 3 Numbers: ";
std::cin >> a >> b >> c;
std::cout << "\n";
if (a==b && b==c)
std::cout << "All numbers are the same";
if ((a==b && a!=c) || (a==c && a!=b) || (b==c &&b!=a))
std::cout << "Two numbers are similar";
if ((a!=b) && (a!=c) && (b!=c))
std::cout << 0;
return 0;
}
Объяснение:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая решает данную задачу:
cpp#include <iostream>
#include <sstream>
#include <unordered_map>
int main() {
std::string input;
std::getline(std::cin, input);
std::istringstream iss(input);
int num;
std::unordered_map<int, int> numCount;
while (iss >> num) {
numCount[num]++;
}
int sameCount = 0;
for (const auto& pair : numCount) {
if (pair.second > 1) {
sameCount++;
}
}
std::cout << sameCount << std::endl;
return 0;
}
Вы можете скопировать этот код в файл с расширением .cpp, скомпилировать его с помощью компилятора C++ (например, g++), а затем запустить получившийся исполняемый файл. Программа считает три целых числа из входной строки, подсчитает количество одинаковых чисел и выведет это количество на экран.
Похожие вопросы
Информатика 17
Информатика 82
Информатика 98
Информатика 98
Информатика 31
Информатика 163
Информатика 251
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
