Вопрос задан 05.01.2019 в 01:28.
Предмет Информатика.
Спрашивает Беркут Настя.
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой
цепочке. Входные данные Входная строка содержит три целых числа, разделённых пробелами. Выходные данные Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные. Примеры входные данные 1 2 1 выходные данные 2На ПаскалеОтветы на вопрос
Отвечает Кибешова Алиса.
Var a,b,c:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if (a=b)and(b=c)
then writeln(3)
else if (a=b)or(a=c)or(b=c) then writeln(2)
else writeln(0);
end.
Пример:
a, b, c:
1 2 1
2
begin
writeln('a, b, c:');
readln(a,b,c);
if (a=b)and(b=c)
then writeln(3)
else if (a=b)or(a=c)or(b=c) then writeln(2)
else writeln(0);
end.
Пример:
a, b, c:
1 2 1
2
Отвечает Маклакова Мария.
Var
a,b,c,k:integer;
begin
k:=1;
Read(a,b,c);
if a=b then Inc(k);
if a=c then Inc(k);
if (b=c) and (k=1) then k:=2;
Writeln(k)
end.
a,b,c,k:integer;
begin
k:=1;
Read(a,b,c);
if a=b then Inc(k);
if a=c then Inc(k);
if (b=c) and (k=1) then k:=2;
Writeln(k)
end.
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
