Вопрос задан 10.07.2023 в 09:04. Предмет Информатика. Спрашивает Талалаев Саша.

Помогите пожалуйста написать программу на C# В данной действительной квадратной матрице порядка n

найти сумму элементов строки, в которой расположен элемент с наименьшим значением. Предполагается, что такой элемент единствен.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мельников Андрей.

Ответ:

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n,i,j, imin = 0;

           double sum = 0;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           double[,] A = new double[n, n];

           Random r = new Random();

           for (i = 0; i < n; i++)

           {

               for (j = 0; j < n; j++)

               {

                   A[i, j] = r.NextDouble()*100 - 50;

                   Console.Write("{0,10:0.0}", A[i, j]);

                   if (A[i, j] < A[imin / 10, imin % 10]) imin = i * 10 + j;

               }

               Console.WriteLine();

           }

           i = imin / 10;

           for (j = 0; j < n; j++) sum += A[i, j];

           Console.WriteLine("Сумма элементов строки с наименьшим значением: {0,10:0.0}", sum);

       }

   }

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C#, которая решает данную задачу:

csharp
using System; namespace MinValueRowSum { class Program { static void Main(string[] args) { Console.Write("Введите порядок матрицы: "); int n = int.Parse(Console.ReadLine()); int[,] matrix = new int[n, n]; Console.WriteLine("Введите элементы матрицы:"); for (int i = 0; i < n; i++) { string[] rowValues = Console.ReadLine().Split(' '); for (int j = 0; j < n; j++) { matrix[i, j] = int.Parse(rowValues[j]); } } int minRowIndex = 0; int minElement = matrix[0, 0]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { if (matrix[i, j] < minElement) { minElement = matrix[i, j]; minRowIndex = i; } } } int sum = 0; for (int j = 0; j < n; j++) { sum += matrix[minRowIndex, j]; } Console.WriteLine($"Сумма элементов строки с минимальным значением ({minElement}): {sum}"); } } }

Программа сначала запрашивает порядок матрицы (количество строк и столбцов), затем поочередно запрашивает элементы матрицы. После того как матрица введена, программа находит строку с наименьшим элементом и вычисляет сумму элементов этой строки. Результат выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос