Вопрос задан 09.07.2023 в 17:56.
Предмет Информатика.
Спрашивает Васильева Катя.
ОЧЕНЬ СРОЧНО!!! УМОЛЯЮ На Паскале с клавиатуры вводится величина I - информационный объем файла в
Кб. Составьте программу перевода этой величины в байты, биты, Мб и вывода их на экран. 8 класс без case ofОтветы на вопрос
Отвечает Кикин Тимур.
program gwr;
var
i : integer;
begin
writeln('Введите объём файла в Кб');
readln(i);
writeln('Информационный объём в битах равен:', i * 1024 * 8);
writeln('Информационный объём в байтах равен: ', i * 1024);
writeln('Информационный объём в Мегабайтах равен: ', i /1024);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль для перевода информационного объема из Кб в байты, биты и Мб:
pascalprogram Conversion; var I_Kb, I_Bytes, I_Bits: Integer; I_Mb: Real; begin writeln('Введите информационный объем файла в Кб:'); readln(I_Kb); I_Bytes := I_Kb * 1024; I_Bits := I_Bytes * 8; I_Mb := I_Kb / 1024; writeln('Информационный объем файла:'); writeln(I_Bytes, ' байт'); writeln(I_Bits, ' бит'); writeln(I_Mb:0:2, ' Мб'); end.
Скопируйте этот код в среду разработки на Паскале и выполните программу. Она попросит вас ввести информационный объем файла в Кб и выдаст соответствующие значения в байтах, битах и Мб.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
