Вопрос задан 09.07.2023 в 15:54. Предмет Информатика. Спрашивает Юзыхович Егор.

На паскале. 4. Девятиклассники участвовали в викторине по математике. Необходимо было ответить на

20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов. Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Temir Diko.

var N, i, a, m:integer;

c:boolean;

begin

 writeln('Введите количество участников');

 readln(N);

 if ((N < 1) or (N >50))then begin

   writeln('Ошибка');

   exit;

 end;

 m := 0;

 c := false;

 for i:=1 to N do begin

   writeln('На сколько вопросов правильно ответил ',i,' участник:');

   readln(a);

   if ((a < 0) or (a > 20)) then begin

     writeln('Ошибка');

     exit;

   end;

   

   if (a = 0) then

     c := true;

   

   if (a > m) then

     m:= a;

 end;

 writeln('Количество вопросов, на которые ответил победитель правильно: ', m);

 if (c = false) then

   writeln('Есть ли участники, которые не ответили ни на один вопрос правильно: NO')

 else write('Есть ли участники, которые не ответили ни на один вопрос правильно: YES');

 

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Приведу пример кода на Pascal, который решает данную задачу:

pascal
program QuizResults; var N, maxCorrect, correctAnswers: integer; i: integer; hasParticipantWithNoCorrectAnswers: boolean; begin // Ввод количества участников readln(N); maxCorrect := 0; hasParticipantWithNoCorrectAnswers := false; // Цикл для каждого участника for i := 1 to N do begin // Ввод количества правильных ответов у текущего участника readln(correctAnswers); // Обновление максимального количества правильных ответов if correctAnswers > maxCorrect then maxCorrect := correctAnswers; // Проверка наличия участника без правильных ответов if correctAnswers = 0 then hasParticipantWithNoCorrectAnswers := true; end; // Вывод результата writeln(maxCorrect); if hasParticipantWithNoCorrectAnswers then writeln('YES') else writeln('NO'); end.

Вы можете использовать этот код, чтобы решить задачу на Pascal, предоставив количество участников викторины и количество правильных ответов для каждого участника. Код определит, сколько правильных ответов дал победитель и есть ли участники без правильных ответов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос