Вопрос задан 09.07.2023 в 11:38.
Предмет Информатика.
Спрашивает Султаггазы Каракат.
Составьте программу, по которой будет реализован следующий сценарий: 1. компьютер запрашивает
Ваше имя, ввести имя с клавиатуры. 2. компьютер запрашивает Ваш год рождения, ввести год рождения. 3. после ввода компьютер сообщает ваш возраст (количество лет). 4. Для расчета от текущего года надо вычесть год Вашего рождения. Например, если ввели имя Иван, год рождения 2005, то выведется фраза «Иван тебе 15 лет». паскальОтветы на вопрос
Отвечает Смирнов Евгений.
Ответ:
PascalABC
Объяснение:
program vozrast;
var
name: string;
year, age: integer;
d: datetime;
begin
Write('Введите имя: ');
ReadLn(name);
Write('Введите год рождения: ');
ReadLn(year);
d := DateTime.Now;
age := d.Year - year;
WriteLn(name,', тебе ', age, ' лет.');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, реализующей данный сценарий:
pascalprogram CalculateAge; var name: string; birthYear, currentYear, age: integer; begin // Запрос имени пользователя writeln('Введите ваше имя:'); readln(name); // Запрос года рождения пользователя writeln('Введите ваш год рождения:'); readln(birthYear); // Получение текущего года currentYear := 2023; // Замените 2023 на текущий год // Расчет возраста age := currentYear - birthYear; // Вывод возраста пользователя writeln(name, ', вам ', age, ' лет.'); end.
Программа запрашивает имя пользователя, год рождения и вычисляет возраст на основе текущего года (здесь предполагается, что текущий год - 2023). Затем она выводит фразу с именем и возрастом пользователя. Вы можете изменить значение переменной currentYear на актуальный текущий год при необходимости.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
