 
Вопрос задан 08.07.2023 в 23:55.
Предмет Информатика.
Спрашивает Бах Женя.
Ребят помогите!! Паскаль Напишите программу, которая в последовательности целых чисел определяет
разность количества четных и нечетных чисел. Программа получает на вход числа последовательности, условием остановки является ввод числа 0. Количество чисел заранее неизвестно, но не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число — разность количества четных и нечетных чисел. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Корниенко Борислав.
                
    Ответ:
PascalABC.NET 3.6.2
begin
var S := ReadSeqIntegerWhile(p -> p <> 0).ToList;
var odd := S.Where(p -> p mod 2 <> 0).Count;
var even := S.Where(p -> p mod 2 = 0).Count;
var diff := abs(even - odd);
diff.Println;
end.
 0
                    0
                     0
                    0
                 
        Отвечает Котик-Злобина Люба.
                
    // PascalABC.NET
begin
var diff := 0;
ReadSeqIntegerWhile(p -> p <> 0)
.Foreach(p -> begin diff += p.IsOdd ? -p : p end);
diff.Print
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на языке Паскаль, которая решает данную задачу:
pascalprogram DifferenceEvenOddCount; var num, evenCount, oddCount: integer; begin evenCount := 0; oddCount := 0; repeat readln(num); if num <> 0 then begin if num mod 2 = 0 then evenCount := evenCount + 1 else oddCount := oddCount + 1; end; until num = 0; writeln('Разность количества четных и нечетных чисел: ', evenCount - oddCount); end.
Эта программа считывает числа, пока не будет введено число 0. Если введено нечетное число, увеличивается счетчик нечетных чисел, а если четное, то увеличивается счетчик четных чисел. По завершении ввода программа выводит разность количества четных и нечетных чисел.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			