Вопрос задан 08.07.2023 в 15:22. Предмет Информатика. Спрашивает Сенькевич Владислав.

Помогите пожалуйста!! (Это нужно в Python)!!! Составить программу. • Ввести целое трехзначное

число N>0. • Найти сумму цифр данного числа. Вывести на печать с пояснениями. • Если сумма цифр ≥14, напечатать «да», иначе напечатать «нет».
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кириллова Стася.

Ответ:

n=int(input())

s=n%10+(n//100)+((n%100)//10)

if s>=14:

   print ('да')

else:

   print ('нет')

Объяснение:

s=n%10+(n//100)+((n%100)//10)

n%10 - находит последнюю цифру числа

n//100 - находит 1 цифру числа

(n%100)//10 - находит 2 цифру числа

Если мой ответ оказался Вам полезен, то прошу отметить его, как "лучший"

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам составить программу на Python для выполнения задачи. Вот пример решения:

python
# Ввод целого трехзначного числа N N = int(input("Введите целое трехзначное число N: ")) # Находим сумму цифр числа N сумма_цифр = 0 temp = N while temp > 0: сумма_цифр += temp % 10 temp //= 10 # Вывод суммы цифр print("Сумма цифр числа", N, "составляет", сумма_цифр) # Проверка условия и вывод результата if сумма_цифр >= 14: print("Да") else: print("Нет")

В этой программе мы сначала запрашиваем у пользователя трехзначное число N. Затем мы находим сумму цифр этого числа, используя цикл while и операции деления нацело (//) и остатка от деления (%). После этого мы выводим сумму цифр на печать.

Затем мы проверяем условие сумма_цифр >= 14 и выводим "Да", если условие выполняется, или "Нет" в противном случае.

Пожалуйста, обратите внимание, что код предполагает, что вводимое число будет трехзначным и положительным.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос