Вопрос задан 08.07.2023 в 10:15. Предмет Информатика. Спрашивает Алексеева Юля.

СРОЧНО Написать программу которая выводит степени чисел 2 до 15(2'1, 2'2, 2'3 ... 2'15)P.S На С++

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бродский Иосиф.

#include <iostream>

int main()

{

using namespace std;

setlocale(LC_ALL, "Russian");  // русский язык

int num = 2;

cout << "Степень: Отсутствует. Число: " << num << endl;  

for(int i = 2; i<16; ++i)  { // цикл где 13 раз умножаем num на 2

cout << "Степень: " << i;

num=num*2;

cout << " Число: " << num << endl; // выводим

}

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке C++, которая выводит степени числа 2 от 1 до 15:

cpp
#include <iostream> int main() { for (int i = 1; i <= 15; i++) { long long result = 1; for (int j = 1; j <= i; j++) { result *= 2; } std::cout << "2^" << i << " = " << result << std::endl; } return 0; }

Эта программа использует два вложенных цикла. Внешний цикл выполняется для значений от 1 до 15, внутренний цикл выполняет умножение на 2 нужное количество раз для получения степени. Результат каждой степени выводится на экран.

Если вы скомпилируете и запустите эту программу, она выведет следующий результат:

yaml
2^1 = 2 2^2 = 4 2^3 = 8 2^4 = 16 2^5 = 32 2^6 = 64 2^7 = 128 2^8 = 256 2^9 = 512 2^10 = 1024 2^11 = 2048 2^12 = 4096 2^13 = 8192 2^14 = 16384 2^15 = 32768

Надеюсь, это помогло! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос