Вопрос задан 08.07.2023 в 02:45.
Предмет Информатика.
Спрашивает Брусак Тёма.
30 баллов Напишите программу, которая в последовательности натуральных чисел определяет
максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. Паскаль.Ответы на вопрос
Отвечает Дорошенко Женя.
var
n:word;
a,max,i:integer;
begin
repeat
write ('N = ');readln(n);
until (n>0) and (n<=1000);
write ('A = ');readln(a);
if a mod 5 = 0 then max:=a;
while i<>n-1 do begin
write ('A = ');readln(a);
if (a>max) and (a mod 5 = 0) then max:=a;
i:=i+1;
end;
writeln ('Max: ',max);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая выполняет задачу:
pascalprogram MaxMultipleOf5; var n, i, number, maxMultiple: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); writeln('Введите числа:'); maxMultiple := -1; // Инициализируем переменную максимального числа, кратного 5 for i := 1 to n do begin readln(number); // Проверяем, является ли число кратным 5 и больше текущего максимального if (number mod 5 = 0) and (number > maxMultiple) then maxMultiple := number; end; if maxMultiple = -1 then writeln('В последовательности нет чисел, кратных 5.') else writeln('Максимальное число, кратное 5: ', maxMultiple); end.
Программа сначала запрашивает количество чисел в последовательности, затем вводит сами числа. В ходе цикла проверяется каждое число: если оно кратно 5 и больше текущего максимального числа (или если текущий максимум еще не установлен), то оно становится новым максимальным числом, кратным 5. По окончании цикла программа выводит результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
