
Напишите программу на ПАСКАЛЕ, которая вводит с клавиатуры рассматриваемые числа (ваши оценки по
предмету) и выводит их и их среднее арифметическое значение (средний балл).

Ответы на вопрос

PascalABC.NET
Ответ:
- begin
- var a := ReadArrInteger(ReadInteger('Введите количество:'));
- a.Println;
- Println('Средний балл:', a.Average);
- end.
Пример:




Конечно! Вот пример программы на Паскале, которая выполняет указанные вами задачи:
pascalprogram CalculateAverage; var numGrades, i, gradeSum: Integer; grade, average: Real; begin Write('Введите количество оценок: '); ReadLn(numGrades); gradeSum := 0; for i := 1 to numGrades do begin Write('Введите оценку ', i, ': '); ReadLn(grade); gradeSum := gradeSum + Trunc(grade); end; average := gradeSum / numGrades; WriteLn('Оценки:'); for i := 1 to numGrades do begin WriteLn('Оценка ', i, ': ', Trunc(grade)); end; WriteLn('Средний балл: ', average:0:2); end.
В данной программе вы сначала вводите количество оценок (numGrades
), а затем в цикле for
вводите каждую оценку по очереди. Сумма оценок сохраняется в переменной gradeSum
. После окончания ввода оценок, вычисляется средний балл (average
) путем деления суммы оценок на количество оценок.
Затем программа выводит список всех оценок, а затем выводит средний балл с двумя знаками после запятой.
Примечание: В данном примере предполагается, что оценки являются целыми числами. Если оценки могут быть десятичными числами, замените Trunc(grade)
на grade
при выводе оценок и при вычислении среднего балла.
Надеюсь, это поможет вам! Если у вас возникнут ещё вопросы, пожалуйста, дайте мне знать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili