Вопрос задан 07.07.2023 в 19:51. Предмет Информатика. Спрашивает Уфимцева Жанна.

Напишите программу угадывания пароля с использованием цикла WHILE (повторять ввод пароля

пользователем, пока он не совпадёт с тем, который "зашифрован в программе")
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Молчанова Милена.

Ответ:

var

pin : integer;

readPin : integer;

 

begin

 pin := 1234; //здесь напишешь  свой пин

  writeln('Write Pin :');

 readln(readPin);

 while readPin <> pin do begin

   writeln('Error wrong pin!');

   readln(readPin);

 end;

end.

Объяснение:

Вот

0 0
Отвечает Еслямгалиева Аружан.

import random

code = ["954321"]

mineC = []

final = ""

i = 0

while True:

   while i < 6:

       wordC = random.randint(0, 9)

       mineC.append(wordC)

       i += 1

   if mineC != code:

       print(mineC)

       mineC.clear()

   if mineC == code:

       for i in mineC:

           final += i

       break

Работает только с паролями с цифрами

иначе придется выстраивать буквы по індексу и вызывать их так

   

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая реализует угадывание пароля с использованием цикла while:

python
# "Зашифрованный" пароль encrypted_password = "mysecretpassword" # Начинаем бесконечный цикл угадывания пароля while True: # Пользователь вводит пароль user_input = input("Введите пароль: ") # Проверяем, совпадает ли введенный пароль с "зашифрованным" if user_input == encrypted_password: print("Пароль верный. Доступ разрешен.") break # Выходим из цикла else: print("Пароль неверный. Попробуйте снова.")

Обратите внимание, что это довольно простой способ угадывания пароля, и в реальных программах обычно применяются более сложные методы шифрования и проверки пароля для обеспечения безопасности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос