Дан массивдействительных чисел,размерность которого n.подсчитать, сколько в нем отрицательных,
положительных чисел Напишите программу,которая Выводит на экран массив и количество положительных и отрицательных чисел Ответы на вопрос
        Ответ:
program mas;
uses crt;
var
i,pol,otr,nul:integer;
x:array[1..100]of real;
n:integer;
begin
writeln('vvedite n');
readln(n);
otr:=0;
pol:=0;
nul:=0;
for i:=1 to n do begin
readln(x[i]);
if x[i]<0 then otr:=otr+1;
if x[i]>0 then pol:=pol+1;
if x[i]=0 then nul:=nul+1;
end;
writeln('polojit',pol);
writeln('otricat',otr);
writeln('nulev',nul);
readln;
end.
Объяснение:
        Ответ:
--- PascalABC.NET 3.6.2 ---
begin
var (neg, pos) := (0, 0);
var n := ReadInteger();
ArrRandomReal(n, -99, 99).Println.ForEach(p -> begin if (p < 0) then neg += 1 else pos += 1 end);
Print($'Positive numbers: {pos}; Negative: {neg}');
end.
Объяснение:
            Конечно! Вот пример программы на языке Python, которая выводит массив, а также подсчитывает количество положительных и отрицательных чисел:
pythondef count_positive_negative_numbers(array):
    positive_count = 0
    negative_count = 0
    for number in array:
        if number > 0:
            positive_count += 1
        elif number < 0:
            negative_count += 1
    print("Массив:", array)
    print("Количество положительных чисел:", positive_count)
    print("Количество отрицательных чисел:", negative_count)
# Пример использования
array = [-2, -1, 0, 3, 5, -4, -6, 7, 8]
count_positive_negative_numbers(array)
В этом примере функция count_positive_negative_numbers принимает массив в качестве аргумента. Затем она проходит по каждому элементу массива и увеличивает счетчик положительных чисел (positive_count), если число больше 0, и счетчик отрицательных чисел (negative_count), если число меньше 0. Затем она выводит на экран массив и количество положительных и отрицательных чисел.
Примечание: В этом примере предполагается, что массив уже определен. Если вы хотите, чтобы пользователь вводил массив, вы можете добавить код для его ввода перед вызовом функции count_positive_negative_numbers.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			