
C++ Нарисовать блок-схему и написать программу для решения задач: 1. Дано число. Если оно меньше
7, то вывести Yes, если больше 10, то вывести No, иначе вывести Error. 2. Даны два числа. Если первое число больше второго, то вывести yes, иначе поменять значения этих переменных и вывести их на экран. 3. Даны два числа. Определить, являются ли числа одного знака или хотя бы одно из них равно нулю. (Подсказка: чтобы определить какого знака числа, нужно посмотреть на их произведение)

Ответы на вопрос

Ответ:
1 задача:
#include <bits/stdc++.h>
using namespace std;
int main() {
long long a;
cin >> a;
if (a < 7) cout << "Yes";
else if (a > 10) cout << "No";
else cout << "Error";
return 0;
}
2 задача:
#include <bits/stdc++.h>
using namespace std;
int main() {
long long a, b;
cin >> a >> b;
if (a > b) cout << "yes";
else {
long long c = a;
a = b;
b = c;
cout << a << ' ' << b << endl;
}
return 0;
}
3 задача:
#include <bits/stdc++.h>
using namespace std;
int main() {
long long a, b;
cin >> a >> b;
if (a * b >= 0) cout << "YES";
else cout << "NO";
return 0;
}



Пожалуйста, вот блок-схемы и соответствующие программы для решения данных задач на C++:
Задача 1:
Блок-схема:
lua +----------------+
| Ввод числа x |
+----------------+
|
v
+----------------+
| x < 7? |
+----------------+
| |
v v
+-------+ +-----------+
| Вывод | | x > 10? |
| Yes | +-----------+
+-------+ | |
v v
+-------+ +-------+
| Вывод | | Вывод |
| No | | Error |
+-------+ +-------+
Программа на C++:
cpp#include <iostream>
int main() {
int x;
std::cout << "Введите число: ";
std::cin >> x;
if (x < 7) {
std::cout << "Yes" << std::endl;
} else if (x > 10) {
std::cout << "No" << std::endl;
} else {
std::cout << "Error" << std::endl;
}
return 0;
}
Задача 2:
Блок-схема:
lua +------------------+
| Ввод числа a, b |
+------------------+
|
v
+------------------+
| a > b? |
+------------------+
| |
v v
+-------+ +-----------+
| Вывод | | Поменять |
| yes | | значения |
+-------+ | переменных|
+-----------+
|
v
+------------------+
| Вывод значений a,|
| b |
+------------------+
Программа на C++:
cpp#include <iostream>
int main() {
int a, b;
std::cout << "Введите два числа: ";
std::cin >> a >> b;
if (a > b) {
std::cout << "yes" << std::endl;
} else {
std::swap(a, b);
std::cout << "Значения переменных поменялись местами: a = " << a << ", b = " << b << std::endl;
}
return 0;
}
Задача 3:
Блок-схема:
lua +------------------+
| Ввод чисел a, b |
+------------------+
|
v
+------------------+
| a * b > 0 или |
| a == 0 или b == 0|
+------------------+
| |
v v
+-------+ +-----------+
| Вывод | | Вывод |
| Один | | Разные |
| знак | | знаки или |
| или | | одно из |
| ноль | | них равно |
+-------+ | нулю |
+-----------+
Программа на C++:
cpp#include <iostream>
int main() {
int a, b;
std::cout << "Введите два числа: ";
std::cin >> a >> b;
if ((a * b > 0) || (a == 0) || (b == 0)) {
std::cout << "Один знак или одно из чисел равно нулю" << std::endl;
} else {
std::cout << "Разные знаки" << std::endl;
}
return 0;
}
Примечание: Эти программы предполагают корректный ввод пользователем чисел.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili