Вопрос задан 06.07.2023 в 23:46.
Предмет Информатика.
Спрашивает Исакова Анжелика.
СРОЧНО!!!! ПАСКАЛЬ!!! Напишите программу, которая в последовательности натуральных чисел
определяет количество чисел, оканчивающихся на 0. Программа должна вывести одно число – количество чисел, оканчивающихся на 0. Входные данные: 5 18 10 48 50 44 Выходные данные: 2Ответы на вопрос
Отвечает Усик Антоха.
Ответ:
var
n,i,a,max: integer;
begin
readln(n);
max := -1;
for i := 1 to n do
begin
readln(a);
if (a mod 10 = 3) and (a > max) then
max := a;
end;
writeln(max)
end.
Отвечает Ульянов Стас.
// PascalABC.NET
begin
var n := ReadInteger;
ReadSeqInteger(n).Count(p -> p mod 10 = 0).Print
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, которая решает вашу задачу:
pascalprogram CountNumbersEndingWithZero; var number, count: integer; begin count := 0; // Инициализируем счетчик нулевым значением // Считываем числа до тех пор, пока не встретится 0 while true do begin read(number); // Считываем число if number = 0 then break; // Выходим из цикла, если встретили 0 if number mod 10 = 0 then count := count + 1; // Увеличиваем счетчик, если число оканчивается на 0 end; writeln(count); // Выводим количество чисел, оканчивающихся на 0 end.
Программа считывает числа, пока не будет введен 0. Если число оканчивается на 0, то увеличивает счетчик count. По завершении цикла программа выводит значение count, которое и является количеством чисел, оканчивающихся на 0.
Пример входных данных:
5 18 10 48 50 44 0
Пример выходных данных:
2
Примечание: Вам может понадобиться настроить окружение и компилятор Паскаля, чтобы запустить программу и получить результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
