Вопрос задан 06.07.2023 в 13:40.
Предмет Информатика.
Спрашивает Хайкина-Юстус Владислава.
составить программу на языке паскальАВС: В МАССИВЕ ИЗ n элементов найти среднее арифметическое
отрицательных и среднее арифметическое положительных.Ответы на вопрос
Отвечает Николаева Ариша.
Ответ:
- begin
- var a := ReadArrInteger(ReadInteger('N:'));
- Println('Отрицательных:', a.Where(x -> x.IsOdd).Average);
- Println('Положительных:', a.Where(x -> x.IsEven).Average);
- end.
Пример работы:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке PascalABC.NET, который решает данную задачу:
pascalprogram AverageValues; const MaxSize = 100; // Максимальный размер массива var arr: array[1..MaxSize] of Integer; n, i, negativeCount, positiveCount: Integer; negativeSum, positiveSum: Real; begin write('Введите количество элементов массива (n): '); readln(n); // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to n do begin write('arr[', i, '] = '); readln(arr[i]); end; // Инициализация переменных для подсчета сумм и количеств negativeCount := 0; positiveCount := 0; negativeSum := 0; positiveSum := 0; // Подсчет сумм и количеств отрицательных и положительных элементов for i := 1 to n do begin if arr[i] < 0 then begin negativeCount := negativeCount + 1; negativeSum := negativeSum + arr[i]; end else if arr[i] > 0 then begin positiveCount := positiveCount + 1; positiveSum := positiveSum + arr[i]; end; end; // Вычисление средних арифметических значений if negativeCount > 0 then begin writeln('Среднее арифметическое отрицательных элементов: ', negativeSum / negativeCount:0:2); end else begin writeln('В массиве нет отрицательных элементов.'); end; if positiveCount > 0 then begin writeln('Среднее арифметическое положительных элементов: ', positiveSum / positiveCount:0:2); end else begin writeln('В массиве нет положительных элементов.'); end; end.
Программа сначала запрашивает количество элементов в массиве, затем просит ввести элементы. После этого она подсчитывает суммы и количество отрицательных и положительных элементов, а затем вычисляет и выводит средние арифметические значения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
