Вопрос задан 06.07.2023 в 07:36.
Предмет Информатика.
Спрашивает Кузин Арсений.
Написать программу. Дано двузначное число N и однозначное M. Проверить, есть ли среди цифр числа N
число M (на языке паскаль)Ответы на вопрос
Отвечает Турарбек Марат.
Ответ:
--- PascalABC.NET 3.6.2 ---
begin
var (N, M) := ReadString2();
if N.Contains(M) then println('Number N contains digit M') else println('No match');
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая выполняет заданную задачу:
pascalprogram CheckDigits; var N, M, tempN: integer; digitFound: boolean; begin writeln('Введите двузначное число N:'); readln(N); writeln('Введите однозначное число M:'); readln(M); if (N < 10) or (N > 99) then begin writeln('Число N должно быть двузначным.'); exit; end; if (M < 0) or (M > 9) then begin writeln('Число M должно быть однозначным.'); exit; end; digitFound := false; tempN := N; while tempN > 0 do begin if tempN mod 10 = M then begin digitFound := true; break; end; tempN := tempN div 10; end; if digitFound then writeln('Цифра ', M, ' найдена в числе ', N) else writeln('Цифра ', M, ' не найдена в числе ', N); end.
Скопируйте этот код в среду программирования, поддерживающую Pascal, и выполните его. Программа попросит вас ввести двузначное число N и однозначное число M, после чего она проверит, содержится ли цифра M среди цифр числа N.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
