Написать программу, которая вводит массив из 6 столбцов и 4 строк, в котором значение каждого
элемента соответствует номеру столбца. Также нужно вывести на экран полученный массив, числа в строке должны быть разделены запятой с пробелом, а в конце строки никаких знаков быть не должно. (паскаль)Ответы на вопрос
Ответ:
--- PascalABC.NET 3.6.2 ---
const row = 4;
const col = 6;
procedure MatrixPrintln<T>(Matrix: Array[,] of T; LineSep: string);
begin
foreach var mRow in Matrix.Rows do begin
string.Join(LineSep, mRow).Println;
end;
end;
begin
var Matrix := new integer[row,col];
for var i := 0 to row-1 do begin
for var k := 0 to col-1 do begin
Matrix[i,k] := k+1;
end;
end;
matrixPrintln(Matrix, ', ');
end.
PascalABC.NET
Ответ:
- begin
- foreach var r in MatrGen(4,6,(i,j)->j+1).Rows do r.Println(', ');
- end.
Пример работы:

Конечно, вот пример программы на языке Pascal, которая выполняет указанные вами действия:
pascalprogram ColumnArray; var arr: array[1..4, 1..6] of Integer; i, j: Integer; begin // Ввод массива for i := 1 to 4 do for j := 1 to 6 do arr[i, j] := j; // Вывод массива for i := 1 to 4 do begin for j := 1 to 6 - 1 do Write(arr[i, j], ', '); WriteLn(arr[i, 6]); end; end.
Эта программа создает массив с 4 строками и 6 столбцами, где значение каждого элемента соответствует номеру столбца. Затем она выводит этот массив на экран, разделяя числа в строке запятыми с пробелом и без знака в конце строки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
