Вопрос задан 05.07.2023 в 19:33.
Предмет Информатика.
Спрашивает Тарабаев Святослав.
на паскаль Саша и Петя играют в игру. Сначала Саша придумывает числу А, а Петя подбирает к нему не
меньшее число В. Потом Саша выписывает на листе все числа от A до B(включительно) и зачеркивает те числа, сумма цифр которых чётна. Дальнейший ход игры зависит от количества оставшихся чисел, поэтому Пете важно подобрать правильное число. Помогите Пете написать программку, которая будет высчитывать количество чисел оставшихся после вычеркивания всех чисел с четной суммой цифр. Формат ввода Программа получает на вход два натуральных числа A и B,A < B. Формат вывода Программа должна вывести единственное число - количество чисел с нечётной суммой цифриз выписанных на листе.Ответы на вопрос
Отвечает Корецкая Ольга.
Ответ:
х=6 - задуманное число
Обьяснение:
х - задуманное число
(7х-6):6=6
7х-6=6·6
7х-6=36
7х=36+6
7х=42
х=42:7
х=6
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая решает эту задачу:
pascalprogram Game; var A, B, num, digit, sum, count: integer; function IsEven(num: integer): boolean; begin IsEven := num mod 2 = 0; end; begin readln(A, B); count := 0; for num := A to B do begin sum := 0; // Вычисляем сумму цифр числа num while num > 0 do begin digit := num mod 10; sum := sum + digit; num := num div 10; end; // Если сумма цифр нечетная, увеличиваем счетчик if not IsEven(sum) then Inc(count); end; writeln(count); end.
Программа сначала считывает числа A и B, а затем проходит через все числа от A до B включительно. Для каждого числа вычисляется сумма его цифр, и если эта сумма нечетная, то увеличивается счетчик count. По окончании цикла выводится значение счетчика, представляющее количество чисел с нечетной суммой цифр.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
