Вопрос задан 05.07.2023 в 19:15.
Предмет Информатика.
Спрашивает Прокопцова Настя.
НА ЯЗЫКЕ ПАСКАЛЬ РЕШИТЬ Вася еще не ходит в школу и только учиться считать. Старший брат Васи -
Петя уже первоклассник и даже знает про отрицательные числа и, уж тем более, умеет числа складывать(правда, пока только целые). Но вот про существование 0, Петя забыл. Однако, кроме математики, Петя увлекается программированием и попросил вас помочь написать ему программу для сложения и вычитания целых чисел без учета 0( то есть ряд целых чисел выглядит так: ...,−3,−2,−1, 1, 2, 3, ...). Формат ввода Первая строка входных данных содержит число N. Вторая строка содержит число M. Формат вывода Программа должна вывести одно целое число - сумму введенных чисел N и M.Ответы на вопрос
Отвечает Птушко Анютка.
Ответ:
решение на фото .. ......

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример кода на языке Pascal, который решает данную задачу:
pascalprogram SumWithoutZero; var N, M, Sum: Integer; begin // Ввод чисел N и M Readln(N); Readln(M); // Проверяем, что числа не равны 0 if (N <> 0) and (M <> 0) then begin // Вычисляем сумму чисел Sum := N + M; // Выводим результат Writeln(Sum); end else begin Writeln('Ошибка: одно из чисел равно 0'); end; end.
Этот код сначала считывает два целых числа N и M, а затем проверяет, что ни одно из них не равно 0. Если оба числа не равны 0, то происходит сложение и выводится результат. Если хотя бы одно из чисел равно 0, программа выводит сообщение об ошибке.
Похожие вопросы
Информатика 78
Информатика 94
Информатика 42
Информатика 62
Информатика 45
Информатика 67
Информатика 157
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
