Вопрос задан 05.07.2023 в 18:04.
Предмет Информатика.
Спрашивает Смирнов Евгений.
Написать программу. Дано трехзначное число. Входит ли в него цифра 4?(с++)
Ответы на вопрос
Отвечает Скорынин Никита.
#include <iostream>
using namespace std;
int main()
{
int x;
cin >> x;
if (x % 10 == 4 or x / 100 == 4 or x / 10 % 10 == 4)
cout << "+";
else
cout << "-";
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая проверяет, входит ли цифра 4 в трехзначное число:
cpp#include <iostream>
int main() {
int number;
std::cout << "Введите трехзначное число: ";
std::cin >> number;
// Получаем отдельные цифры числа
int hundreds = number / 100;
int tens = (number / 10) % 10;
int units = number % 10;
// Проверяем входит ли цифра 4
if (hundreds == 4 || tens == 4 || units == 4) {
std::cout << "Цифра 4 входит в число.\n";
} else {
std::cout << "Цифра 4 не входит в число.\n";
}
return 0;
}
Программа запрашивает у пользователя трехзначное число и проверяет, входит ли цифра 4 в это число. Если цифра 4 входит, программа выводит сообщение "Цифра 4 входит в число", иначе выводит сообщение "Цифра 4 не входит в число".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
