Вопрос задан 05.07.2023 в 15:04. Предмет Информатика. Спрашивает Базарбаев Райымбек.

Программирование на Python. Создайте пж программу простую, с циклом while.Одинаковые цифрыДано

натуральное число. Напишите программу, которая определяет, состоит ли указанное число из одинаковых цифр.Формат входных данных На вход программе подается одно натуральное число.Формат выходных данныхПрограмма должна вывести «YES» если число состоит из одинаковых цифр и «NO» в противном случае.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фомина Полина.

Ответ:

--- Python 3.8.3 ---

#1 "Как надо" (С While)

def IsNumberSingledigit(number):

   lastDigit = number % 10

   temp = lastDigit

   flag = True  

   while number > 0:

       lastDigit = number % 10

       if not temp == lastDigit: flag = False  

       temp = lastDigit

       number //= 10

   return flag

def main():

   print(IsNumberSingledigit(int(input())))

   

if __name__ == "__main__":

   main()

#2 Как стоило бы в подобном случае

number = int(input()) #Представляем число как строку

print(True if (len(set(str(number))) == 1) else False)

P.S Приведение сначала к числу а потом обратно к строке нужно для уверенности, что мы работаем именно с числом, а не с "аааааа".

Объяснение:

0 0
Отвечает Зориков Ваня.

number = list(input())

a = number[0]

b = 1

i = 1

while i != len(number):

   if(a == number[i]):

       b += 1

   i += 1

if(b == len(number)):

   print('YES')

else:

   print('NO')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, использующей цикл while, которая проверяет, состоит ли введенное число из одинаковых цифр:

python
def all_digits_are_same(number): # Преобразуем число в строку, чтобы легче работать с цифрами num_str = str(number) # Берем первую цифру в числе как базовую base_digit = int(num_str[0]) # Перебираем остальные цифры и сравниваем их с базовой цифрой for digit in num_str: if int(digit) != base_digit: return False return True # Ввод числа от пользователя num = int(input("Введите натуральное число: ")) # Проверяем и выводим результат if all_digits_are_same(num): print("YES") else: print("NO")

Программа запрашивает у пользователя ввести натуральное число, а затем проверяет, состоит ли данное число из одинаковых цифр. Если все цифры в числе одинаковы, программа выводит "YES", иначе выводит "NO".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос