Вопрос задан 05.07.2023 в 14:04. Предмет Информатика. Спрашивает Сергеев Иван.

1. Составить программу, которая генерирует 10-значный код из букв, цифр и знаков пунктуации. 2.

*Используя строковую функцию isnumber(), которая проверяет, есть ли в строке цифры, должно появляться сообщение, что пароль содержит цифры или нет ().
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тинькова Яночка.

Код написал на Python:

Рандомная строка из букв, цифр и знаков пунктуации:

import random

chars = "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

Проверка на цифры в строке (если будете считать как новую задачу, то знайте, кусок кода взял из первой для генерации случайной строки):

import random

chars = "abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

counter = 0

for i in range(10):

   if (i == 9):

       if (str_result[i].isnumeric() == False):

           print("There is no numbers in string")

   else:

       if (str_result[i].isnumeric() == True):

           print("There is at least one number in string")

           break

       else:

           continue

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Python, которая выполняет заданные вами задачи:

python
import random import string def generate_password(length): characters = string.ascii_letters + string.digits + string.punctuation password = ''.join(random.choice(characters) for _ in range(length)) return password def has_numbers(password): return any(char.isdigit() for char in password) password = generate_password(10) print("Сгенерированный пароль:", password) if has_numbers(password): print("Пароль содержит цифры.") else: print("Пароль не содержит цифры.")

Этот код использует модуль random для генерации случайных символов из заданного набора (буквы, цифры, знаки пунктуации) и модуль string для определения этого набора. Функция generate_password создает пароль заданной длины, а функция has_numbers проверяет наличие цифр в пароле.

Примечание: Поскольку вы просили использовать функцию isnumber(), предполагается, что она уже определена где-то в вашем коде. Однако на момент моего последнего обновления в сентябре 2021 года такой функции не существовало в стандартной библиотеке Python. Вместо этого, в примере выше используется функция has_numbers, которая проверяет наличие цифр в строке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос