C# Написать программу, в которой вводятся с клавиатуры предложения, и выводит на экран только
цитаты, то есть предложения, заключенные в кавычки.Ответы на вопрос
Ответ:
using System;
using System.Text.RegularExpressions;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
string s;
Console.WriteLine("Введите текст:");
s = Console.ReadLine().Replace('\"','\'');
Regex r = new Regex(@"'[^']+'");
foreach (Match m in r.Matches(s))
Console.WriteLine(m.Value);
}
}
}
Конечно! Вот пример программы на C#, которая выполняет задачу, о которой вы спросили:
csharpusing System;
class Program
{
static void Main()
{
Console.WriteLine("Введите предложения:");
string input = Console.ReadLine(); // Читаем введенную строку с клавиатуры
// Разбиваем строку на предложения
string[] sentences = input.Split(new char[] { '.', '!', '?' }, StringSplitOptions.RemoveEmptyEntries);
// Перебираем предложения и выводим только цитаты
foreach (string sentence in sentences)
{
if (sentence.Contains("\""))
{
Console.WriteLine(sentence);
}
}
Console.ReadLine(); // Чтобы консольное окно не закрылось сразу после вывода
}
}
В этой программе мы считываем предложения, введенные с клавиатуры, а затем разбиваем их на отдельные предложения, используя разделители ".", "!" и "?". Затем мы перебираем каждое предложение и проверяем, содержит ли оно символ кавычек """. Если содержит, то выводим предложение на экран.
Примечание: В этой программе мы предполагаем, что кавычки будут использоваться в виде пары, то есть каждое предложение будет иметь открывающую и закрывающую кавычки. Если требуется поддерживать цитаты, заключенные в одиночные кавычки или несбалансированные кавычки, программа должна быть изменена соответствующим образом.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
