Вопрос задан 05.07.2023 в 12:26. Предмет Информатика. Спрашивает Афанасьев Матвей.

Составьте программу, которая по коду операции N выполняет над целыми числами а и b (b0)

указанное действие и выводит результат. Арифметические действия (операции) над числами обозначены: 1 – сложение, 2 – вычитание, 3 – умножение, 4 – деление.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Прохисова Настя.

var x,y,cmd, z: integer;

begin

 readln(x,y);

 readln(cmd);

 if cmd = 1 then

   z:=x+y;

 if cmd = 2 then

   z:=x-y;

 if cmd = 3 then

   z:=x*y;

 if cmd = 4 then

   z:=x div y;

 writeln(z);

end.

Краткий гайд: x, y - числа, над которыми производится операция

cmd - код операции

z - результат

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая выполняет указанное действие над целыми числами a и b в соответствии с заданным кодом операции N:

python
a = int(input("Введите число а: ")) b = int(input("Введите число b (не равное нулю): ")) N = int(input("Введите код операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление): ")) if N == 1: result = a + b elif N == 2: result = a - b elif N == 3: result = a * b elif N == 4: result = a / b else: print("Неверный код операции!") exit() print("Результат:", result)

Программа запрашивает у пользователя числа a и b, а также код операции N. Затем она выполняет соответствующее арифметическое действие и выводит результат.

Пожалуйста, обратите внимание, что в этом примере не предусмотрена проверка на деление на ноль (b != 0), поскольку в условии сказано, что b не равно нулю. Однако в реальной программе следует добавить проверку, чтобы избежать ошибок при делении на ноль.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос