Вопрос задан 05.07.2023 в 10:44. Предмет Информатика. Спрашивает Шайхеева Маша.

Решить это на любом языке программирования. Напишите программу, на вход которой с клавиатуры в

первой строке подается натуральное число n ‐ количество показаний прибора (n<12000). Начиная со второй строки, подаются сами показания прибора ‐ целые числа из диапазона [10, 21999999] по одному в строке. Программа должна вывести в порядке убывания те из них, которые меньше среднего арифметического всех показаний.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Маковский Данил.

Написал Вам код на Python-е, держите (также прилагается скриншот с самим кодом и выводом компилятора для наглядного ориентира):

n = int(input('Enter the number of readings of the device: n = '))

readings_list = []

for num_of_readings in range(1,n+1):

       prompt_row = 'Enter ' + str(num_of_readings) + ' reading: '

       reading = int(input(prompt_row))

       readings_list.append(reading)

arithm_mean = 0

for num_of_readings in range(n):

   arithm_mean += readings_list[num_of_readings]

arithm_mean /= n

selected_values_list = []

selected = 0

for num_of_readings in range(n):

   if (readings_list[num_of_readings] < arithm_mean):

       selected = readings_list[num_of_readings]

       selected_values_list.append(selected)

selected_values_list.sort(reverse = True)

if (len(selected_values_list) == 0):

   print('There is no values that are less than the arithmetic mean')

else:

   print('Values that are less than the arithmetic mean - ',*selected_values_list,sep = '  ')


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, который выполняет указанную задачу:

python
def main(): n = int(input("Введите количество показаний: ")) # Чтение показаний прибора readings = [] for _ in range(n): reading = int(input()) readings.append(reading) # Вычисление среднего арифметического average = sum(readings) / n # Фильтрация и вывод показаний меньше среднего below_average = [reading for reading in readings if reading < average] below_average.sort(reverse=True) # Сортировка по убыванию for reading in below_average: print(reading) if __name__ == "__main__": main()

Вы можете вставить этот код в файл с расширением .py и запустить его. Программа будет последовательно запрашивать количество показаний и сами показания прибора, а затем выведет те из них, которые меньше среднего арифметического всех показаний.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос