Вопрос задан 05.07.2023 в 09:58. Предмет Информатика. Спрашивает Москалёва Арина.

Написать программу на с++ Голодная зима. Суточный рацион коровы составляет u кг сена, v кг силоса

и wкг комбикорма. В хозяйстве, содержащем стадо из k голов, осталось s кг сена, t кг силоса и f кг комбикорма.. В стаде ежедневно погибает p% коров; ежедневно q% оставшегося сена сгнивает; r% силоса разворовывается колхозниками; t% комбикорма распродает зав. фермой. Когда нельзя будет кормить всех оставшихся коров по полному рациону? Какой из видов кормов кончится раньше других?
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жавкина Ксения.

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

bool myfunction (int i,int j) { return (i<j); } // comparator

int main() {

setlocale(0, "");

srand(time(0));

float u(0.0f), v(0.0f), w(0.0f); //суточный рацион коровы, состоящий из сена, силоса и комбикорма

float k(0.0f); // колво голов в ъозяйстве

float s(0.0f), t(0.0f), f(0.0f); // сколько осталось сена, силоса и комбикорма

float percP(0.0f); //  в день погибает % коров

float percQ(0.0f), percR(0.0f), percT(0.0f); //  в день сгнивает сена, силоса и комбкорма %

int dayCounter = 0;

cout << "Сена в день: ";

cin >> u;

cout << "Силоса в день: ";

cin >> v;

cout << "Комбикорма в день: : ";

cin >> w;

cout << "Всего коров: ";

cin >> k;

cout << "Осталось сена: ";

cin >> s;

cout << "Осталось силоса: ";

cin >> t;

cout << "Осталось комбикорма: ";

cin >> f;

cout << "Сколько % в день погибает коров: ";

cin >> percP;

cout << "Сколько % пропадает сена: ";

cin >> percQ;

cout << "Сколько % пропадает силоса: ";

cin >> percR;

cout << "Сколько % пропадает комбикорма: ";

cin >> percT;

while(1) {

if(s<u) {

cout << "Кончилось сено. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(t<v) {

 cout << "Кончился силос. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(f<w) {

 cout << "Кончился комбикорм. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

cout << "День:: " << dayCounter << "    ";

cout << "Осталось коров: " << static_cast<int>(k) << endl;

// кормим коров

s-=u;

t-=v;

f-=w;

//конец дня. Заного считаем припасы и коров.

k=k/100*(100-percP);

s=s/100*(100-percQ);

t=t/100*(100-percR);

f=f/100*(100-percT);

++dayCounter;

}

system("pause");

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи, вы можете написать следующую программу на C++. Программа будет вычислять, через сколько дней закончится каждый вид корма и когда нельзя будет кормить всех коров по полному рациону.

cpp
#include <iostream> using namespace std; int main() { double u, v, w; // Рацион коровы (кг) double s, t, f; // Остатки кормов (кг) int k; // Количество коров double p, q, r, t_percent; // Проценты потерь int days = 0; // Дни // Ввод данных cout << "Введите рацион коровы (кг сена, силоса, комбикорма): "; cin >> u >> v >> w; cout << "Введите остатки кормов (кг сена, силоса, комбикорма): "; cin >> s >> t >> f; cout << "Введите количество коров: "; cin >> k; cout << "Введите проценты потерь (p, q, r, t): "; cin >> p >> q >> r >> t_percent; // Вычисление итеративно while (s >= u * k && t >= v * k && f >= w * k) { s -= u * k; t -= v * k; f -= w * k; // Применяем потери s *= (1 - q / 100); t *= (1 - r / 100); f *= (1 - t_percent / 100); k -= k * p / 100; days++; } // Вывод результатов if (days == 0) { cout << "Можно кормить всех коров по полному рациону." << endl; } else { cout << "Нельзя будет кормить всех коров по полному рациону через " << days << " дней." << endl; } // Определение, какой корм закончится раньше if (s < u * k) { cout << "Закончится сено." << endl; } if (t < v * k) { cout << "Закончится силос." << endl; } if (f < w * k) { cout << "Закончится комбикорм." << endl; } return 0; }

Программа запрашивает ввод различных параметров, вычисляет сколько дней потребуется до тех пор, пока нельзя будет кормить всех коров по полному рациону, и выводит, какой вид корма закончится раньше. Обратите внимание, что это базовый шаблон и может потребовать дополнительных проверок и обработки ошибок для более надежной работы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос