
Помогите написать программу в Pascal. Нужно чтобы пользователь ввёл число из десятичной системы, а
программа переводила его в двоичный код.

Ответы на вопрос

Ответ:
program des_v_dvoich;
uses crt;
var
x,i: integer;
s:String;
begin
write('Введите десятичное число>>');
read(x);
write('Двоичное число>>');
if x<0 then begin
write('-');
x:=abs(x);
end;
if x=0 then
write ('0')
else
begin
while x<>0 do begin
if x mod 2 =1 then
s:=s+'1'
else
s:=s+'0';
x:=x div 2
end;
for i:=length(s) downto 1 do
write(s[i])
end;
end.
Объяснение:
Скрины выполнения прикреплены






PascalABC.NET
Ответ:
Перевод целых чисел в двоичный код:
- function f(x:integer):string := x>0 ? f(x div 2) + x mod 2 : '';
- function ToBinaryCode(Self:integer; n:byte:=8):string; extensionmethod;
- begin
- Result :=
- if Self = 0 then '0'
- else f((Self or Trunc(2**n)) and Trunc(2**n-1)).PadLeft(n, Self>0 ? '0':'1')
- end;
- begin
- ReadInteger.ToBinaryCode.Print;
- end.
Перевод целых чисел в двоичную систему счисления:
- function f(x:integer):string := x>0 ? f(x div 2) + x mod 2 : '';
- function Bin(x:integer):string := x=0 ? '0' : x>0 ? f(x) : '-' + f(Abs(x));
- begin
- Print('x₂:', Bin(ReadInteger('x₁₀:')))
- end.
Пример работы:






Конечно, вот пример программы на Pascal, которая выполняет перевод числа из десятичной системы в двоичную:
pascalprogram DecimalToBinary; var decimalNumber, quotient, remainder: integer; binaryNumber: string; begin writeln('Введите число в десятичной системе:'); readln(decimalNumber); binaryNumber := ''; quotient := decimalNumber; repeat remainder := quotient mod 2; binaryNumber := char(remainder + ord('0')) + binaryNumber; quotient := quotient div 2; until quotient = 0; writeln('Число ', decimalNumber, ' в двоичной системе: ', binaryNumber); end.
Программа запрашивает у пользователя ввести число в десятичной системе, затем она выполняет деление на 2 и сохраняет остатки в строке binaryNumber
. По завершении деления строка будет содержать двоичное представление числа в обратном порядке, поэтому она затем выводится в правильном порядке.
Скопируйте этот код в среду разработки Pascal, например, в среду Turbo Pascal, и выполните его. После запуска программа будет ждать ввода числа от пользователя и выведет его двоичное представление.


Похожие вопросы








Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili