Вопрос задан 05.07.2023 в 07:03. Предмет Информатика. Спрашивает Кокотеев Дмитрий.

Напишите программу в Python, которая получает на вход нижнюю и верхнюю границу диапазона целых

чисел соответственно (ввод нажатием на клавишу после каждого числа), а выводит все числа, которые при делении на 15 дают в остатке 11, а при делении на 11 дают в остатке 9.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бикмаев Линар.

n_bott = int(input("Least number of interval - "))

n_top = int(input("The largest number of interval - "))

num_list = []

for num in range(n_bott,n_top + 1):

   if ((num % 15 == 11) and (num % 11 == 9)):

       num_list.append(num)

print(*num_list)


0 0
Отвечает Ивашков Рома.

Ответ:

#Более экономная по памяти версия

lb, rb = map(int, input('Enter lower and upper range borders:\n').split())

cond = lambda item: item % 15 == 11 and item % 11 == 9

[print(item, end='\n') for item in filter(cond, range(lb, rb+1))]

ввод:

100 1000

вывод

251

416

581

746

911

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, которая выполняет указанные условия:

python
lower_bound = int(input("Введите нижнюю границу: ")) upper_bound = int(input("Введите верхнюю границу: ")) # Проверяем каждое число в заданном диапазоне for num in range(lower_bound, upper_bound + 1): if num % 15 == 11 and num % 11 == 9: print(num)

В этой программе мы используем цикл for, чтобы проверить каждое число в заданном диапазоне (range(lower_bound, upper_bound + 1)). Затем мы проверяем, удовлетворяют ли числа условиям num % 15 == 11 и num % 11 == 9. Если числа удовлетворяют обоим условиям, они выводятся на экран с помощью функции print().

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос