Нужно написать программу в Pascal: пользователь вводит число в десятичной системе, а программа
должна перевести это число в двуичный код. Желательно сделать 1 программу простой, с использованием if, div, mod, ну и циклы если надо,кроме цикла repeat, например пользователь ввёл 5 а система перевела в двуичный код 101Ответы на вопрос
Ответ:
program ToBinary;
procedure dec2bin(var s : string; num : integer);
begin
if num > 0 then begin
dec2bin(s, num div 2);
if num mod 2 = 0 then
s := s + '0'
else
s := s + '1';
end;
end;
var
a : integer;
s : string;
begin
read(a);
dec2bin(s, a);
writeln(s);
end.
Конечно, вот пример программы на Pascal, которая принимает число в десятичной системе и выводит его двоичное представление:
pascalprogram DecimalToBinary; var decimalNum, quotient, remainder, binaryDigit: integer; begin // Ввод числа в десятичной системе write('Введите число в десятичной системе: '); readln(decimalNum); // Вывод двоичного представления write('Двоичное представление числа ', decimalNum, ': '); if decimalNum = 0 then write('0') else begin while decimalNum > 0 do begin quotient := decimalNum; remainder := quotient mod 2; write(remainder); decimalNum := quotient div 2; end; end; writeln; end.
Программа запрашивает у пользователя число в десятичной системе, затем использует оператор div для деления числа на 2 и mod для нахождения остатка от деления, чтобы получить двоичное представление. Программа выполняет цикл до тех пор, пока число больше нуля.
Заметьте, что данная программа работает только для положительных чисел. Если вы хотите добавить поддержку отрицательных чисел или дробных чисел, то потребуется расширить код.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
