Вопрос задан 04.07.2023 в 12:00.
Предмет Информатика.
Спрашивает Совостьянов Родион.
Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c
Ответы на вопрос
Отвечает Кринжуменко Мария.
var
a, b, c, x, x1, x2, d: integer;
begin
readln (a, b, c, x);
writeln ('корень квадратного уравнения с а =', a, ', b = ', b, ', c = ', c);
d = (a * x * x + b * x + c);
x1 = (-b + d)/2*a;
x2 = (-b - d) / 2 *a;
writeln ('первый корень = ', x1);
writeln ('второй корень = ', x2);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal для нахождения корней квадратного уравнения ax^2 + bx + c:
pascalprogram QuadraticEquationSolver; var a, b, c: Real; discriminant, x1, x2: Real; begin writeln('Введите коэффициенты квадратного уравнения ax^2 + bx + c = 0'); write('Введите коэффициент a: '); readln(a); write('Введите коэффициент b: '); readln(b); write('Введите коэффициент c: '); readln(c); discriminant := b * b - 4 * a * c; if discriminant > 0 then begin x1 := (-b + sqrt(discriminant)) / (2 * a); x2 := (-b - sqrt(discriminant)) / (2 * a); writeln('Корни уравнения:'); writeln('x1 = ', x1:0:2); writeln('x2 = ', x2:0:2); end else if discriminant = 0 then begin x1 := -b / (2 * a); writeln('Уравнение имеет один корень:'); writeln('x1 = ', x1:0:2); end else begin writeln('Уравнение не имеет действительных корней.'); end; end.
Скопируйте этот код в среду программирования Pascal (например, Free Pascal) и выполните программу. Она попросит ввести коэффициенты a, b и c, и затем выведет корни уравнения, если они существуют.
Похожие вопросы
Информатика 28
Информатика 19
Информатика 78
Информатика 94
Информатика 26
Информатика 64
Информатика 87
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
