Вопрос задан 02.07.2023 в 09:15.
Предмет Информатика.
Спрашивает Zolotareva Alina.
1. Напишите программу в паскале!!!! Красная Шапочка часто навещает свою бабушку. Но она очень
боится, что рано или поздно ее бабушку опять навестит волк. Поэтому она решила договориться с Лесничим об охране бабушки. Лесничий согласился охранять бабушку за 10 пирожков. Узнав об этом, волк сказал Красной Шапочке, что ей совершенно незачем тратить пирожки на Лесничего. За половину тех пирожков, которые Красная Шапочка несет бабушке, Волк пообещал не трогать ее. 26 ноября в России отмечается день матери. Мама испекла несколько пирожков, и попросила Красную Шапочку отнести их бабушке. Требуется определить, какое максимальное количество пирожков Красная Шапочка сможет донести до бабушки. Входные данные Вводится одно четное натуральное число, не превосходящее 1000 — количество пирожков, которые испекла мама. Выходные данные Программа должна вывести одно число — максимальное количество пирожков, которые Красная Шапочка сможет донести до бабушки. Примеры входные данные 12 выходные данные 6 входные данные 100 выходные данные 90 входные данные 20 выходные данные 10Ответы на вопрос
Отвечает Комякова Татьяна.
program asdasd;
var a:integer;
begin
read(a);
if a / 2 > 10 then begin
writeln(a - 10);
end
else
begin
writeln(a div 2);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, решающая данную задачу:
pascalprogram RedRidingHood; var totalPirozhki, maxPirozhki: integer; begin { Ввод количества пирожков } readln(totalPirozhki); { Вычисление максимального количества пирожков для Красной Шапочки } if totalPirozhki >= 10 then maxPirozhki := totalPirozhki - (totalPirozhki div 2) else maxPirozhki := totalPirozhki; { Вывод результата } writeln(maxPirozhki); end.
Вы можете скопировать этот код и вставить его в среду программирования на Pascal для выполнения и проверки. Программа принимает входное значение - количество пирожков, которые испекла мама, и выводит максимальное количество пирожков, которые Красная Шапочка сможет донести до бабушки.
Похожие вопросы
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
